2024-12-16 API Gateway and Device Gateway Outage

Incident Report for Torizon Cloud Services

Postmortem

Executing an SQL transaction on the database related to OTA-2660 caused the database to lock more rows than expected. This caused director to hang when accessing one of the tables, which caused some features to not be available.

Posted Dec 16, 2024 - 17:27 UTC

Resolved

During a routine maintenance, one service was running with degraded performance and some features were unavailable.
Posted Dec 16, 2024 - 17:25 UTC

Investigating

We are currently experiencing issues with the API Gateway and Device Gateway. Our team has been notified and is actively investigating the issue. Updates will be provided here as soon as possible.
Posted Dec 16, 2024 - 16:27 UTC
This incident affected: App and API Gateway.